Login mot de passe
ONLINE [forum - Accès natifs]

Parcourir ce sujet :   1 Utilisateur(s) anonymes





ONLINE
Aspirant
Inscrit:
2008/5/26 19:26
Messages: 13
Hors Ligne
Bonjour,
J'ai fais des tests PHP4WD sur OVH c'est top ! mais je fais un autre test sur ONLINE apparement la connexion est bonne mais je ne vois pas mes tables MySql ?
Quelqu'un aurait-il une idée ?
Merci d'avance.

Posté le : 2008/5/29 13:30
Transférer la contribution vers d'autres applications Transférer


Re: ONLINE
SQLManagerX Team
Inscrit:
2004/7/1 12:49
De Grenoble (38)
Messages: 2153
Hors Ligne
Bonjour,

en therorie rien ne peut gener je pense qu'ily a un autre souci, il faudrait intercepter une requete pour voir le retour avant decryptage

trace la chaineRetour dans mySQLExec pour voir

Posté le : 2008/5/29 14:04
_________________
----------
Firetox
8 rue Georges Méliès
38130 ECHIROLLES
..............................
http://emidev.fr
http://www.teecod.fr/web/Informatique/accueil
Transférer la contribution vers d'autres applications Transférer


Re: ONLINE
Aspirant
Inscrit:
2008/5/26 19:26
Messages: 13
Hors Ligne
Bonjour "Firetox",
Excuses moi de te soumettre encore mes problemes...
Ce qui me parait bizarre c'est que je mette :

v_retCode = monAccess:mySQLConnecte("http://www.a2gi.com/php4wd.php","user","mp","base")

ou

v_retCode = monAccess:mySQLConnecte("http://www.a2gi.com/www/PHP4/PHP4/php4wd.php","user","mp","base")

Le code retour est toujours 1

Alors que mon php4wd.php est dans /www/PHP4/PHP4/

????

Posté le : 2008/5/29 14:22
Transférer la contribution vers d'autres applications Transférer


Re: ONLINE
SQLManagerX Team
Inscrit:
2004/7/1 12:49
De Grenoble (38)
Messages: 2153
Hors Ligne
je pense que ton lien devrait etre
v_retCode = monAccess:mySQLConnecte("http://www.a2gi.com/PHP4/PHP4/php4wd.php","user","mp","base")

car en fait si tu lance le script depuis un navigateur il doit te renvoyer une page blanche or dans ton cas il renvoie une erreur donc il faut commencer par la

pour le fait que connecte renvoi vrai dans le script il faut mettre la ligne : retCode = Vrai au debut de MySQLConnecte
a retCode = faux


sinon il renvoie touours vrai , e vais verifier mais je pense avoir laisse cette ligne pour mes tests et je ne l'ai pas remis correctement

Posté le : 2008/5/29 14:32
_________________
----------
Firetox
8 rue Georges Méliès
38130 ECHIROLLES
..............................
http://emidev.fr
http://www.teecod.fr/web/Informatique/accueil
Transférer la contribution vers d'autres applications Transférer


Re: ONLINE
Aspirant
Inscrit:
2008/5/26 19:26
Messages: 13
Hors Ligne
Ok, j'ai repris ta syntaxe et voici le message qui apparait avec un retour 0

"Erreur 0"
"You ave an error in your SQL syntax;check the manual... right syntax to use near '3W*O' at line 1'

???

Posté le : 2008/5/29 14:48
Transférer la contribution vers d'autres applications Transférer


Re: ONLINE
SQLManagerX Team
Inscrit:
2004/7/1 12:49
De Grenoble (38)
Messages: 2153
Hors Ligne
Resultat des courses avec un echange de mail en privé :

la cle de cryptage ne doit pas comporter de chiffre. sporty avec une cle avec des lettres + chiffre. nous avons tracé les echanges avec le serveur et regardé les requetes il y avait un probleme sur le decryptage de la requete.

on a essayé avec une cle en lettre et tout a fonctonné
donc le post est clot

je vais mettre a jour php4wd

Posté le : 2008/5/29 14:53

Edité par Firetox sur 29/5/2008 17:01:20
_________________
----------
Firetox
8 rue Georges Méliès
38130 ECHIROLLES
..............................
http://emidev.fr
http://www.teecod.fr/web/Informatique/accueil
Transférer la contribution vers d'autres applications Transférer


Re: ONLINE
SQLManagerX Team
Inscrit:
2004/7/1 12:49
De Grenoble (38)
Messages: 2153
Hors Ligne
je viens de faire un test sur ta base mais comme je ne connais pas le nom de ta base ni la cle que tu as mis je ne devrait pas avoir le meme message or j'ai exactement cela
Citation :


--DEBUTSQL--PHP4WDSEP<p class='Perror'>·Failed - err: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '3W*0' at line 1</p>


donc je me pencheris sur la cle en priorité.

Resultat des courses avec un echange de mail en privé :

la cle de cryptage ne doit pas comporter de chiffre. sporty avec une cle avec des lettres + chiffre. nous avons tracé les echanges avec le serveur et regardé les requetes il y avait un probleme sur le decryptage de la requete.

on a essayé avec une cle en lettre et tout a fonctonné
donc le post est clot

je vais mettre a jour php4wd

Posté le : 2008/5/29 14:59

Edité par Firetox sur 2/6/2008 20:49:44
_________________
----------
Firetox
8 rue Georges Méliès
38130 ECHIROLLES
..............................
http://emidev.fr
http://www.teecod.fr/web/Informatique/accueil
Transférer la contribution vers d'autres applications Transférer


Re: ONLINE
Aspirant
Inscrit:
2008/5/26 19:26
Messages: 13
Hors Ligne
Je n'y comprend plus rien... apparement ma cle est bonne de chaque coté, mais ou j'ai un doute c'est sur la connexion car dans le pavé de recherche des tables il n'en trouve aucune... j'allume une clope et me procure une tasse de café... je veux bien te donner mes acces sur ma base mais plutot en dehors du forum... si t'es d'accord
Mon mail a2gi@wanadoo.fr

Posté le : 2008/5/29 15:19
Transférer la contribution vers d'autres applications Transférer



 Haut   Précédent   Suivant




[Recherche avancée]