Login mot de passe
PHP4WX 9.2.0.0 et utf8 [forum - Accès natifs]

Parcourir ce sujet :   1 Utilisateur(s) anonymes





PHP4WX 9.2.0.0 et utf8
Nouveau
Inscrit:
2017/6/7 10:48
Messages: 2
Hors Ligne
Bonjour,
j'ai installé Php4wx 9.2.0.0 avec windev mobile 21.
quand je fait le test avec

http://localhost/php4wd.php?test=OUI sur une base de données avec un seul champ Nom qui est en arabe dans la table clients.

j'ai le résultat suivant:
-------------------------
--DEBUTSQL--PHP4WDSEPIDClientsPHP4WDSEPNomPHP4WDSEP--LIGNES--PHP4WDSEP3PHP4WDSEPAHMEDPHP4WDSEP2PHP4WDSEP????PHP4WDSEP1PHP4WDSEP????PHP4WDSEP--BINDVARIABLE--PHP4WDSEP--FINSQL--PHP4WDSEP
---------------------

Quand j'ajoute $cmds[] = "SET CHARACTER SET 'UTF8'";
juste avant la requête j'obtiens :
----------------------
version script : PHP4WX 9.2.0.0 du 04/06/2017
version php : 5.4.12

--DEBUTSQL--PHP4WDSEPIDClientsPHP4WDSEPNomPHP4WDSEP--LIGNES--PHP4WDSEP3PHP4WDSEPAHMEDPHP4WDSEP2PHP4WDSEPأحمدPHP4WDSEP1PHP4WDSEPكريمPHP4WDSEP--BINDVARIABLE--PHP4WDSEP--FINSQL--PHP4WDSEP
----------------

qui est le bon résultat, je bloque au niveau de windev mobile 21, impossible d'afficher la langue arabe (أحمد كريم ) par contre AHMED apparaît bien dans la zone répétée .

ci dessous le code utilisé:
----
/// changement de la langue et la page de code
Nation(nationArabe)
ChangeAlphabet(alphabetUTF8)

/// declaration de la classe
monacces est une c_Php4WX

//// connexion a la base mysql
SI PAS monacces:mySQLConnecte("http://localhost/php4wd.php","","","test") ALORS
Info("impossible de trouver le scripte")
SINON
// monacces:mySQLExec ("SET NAMES 'UTF8'",1)
//info("connexion Ok")
FIN

/// la requete
vrequete est une chaîne ="select IDClients,Nom from clients"

vindice est un entier
ZoneRépétéeSupprimeTout(ZR1)

/// affiche dans le ZR1
SI monacces:mySQLExec(vrequete,1) ALORS
TANTQUE monacces:mySQLFetch(1)
// chaque ligne
vindice=ZoneRépétéeAjouteLigne(ZR1)
SI vindice>0 ALORS
ZR1[vindice].lib_id=monacces:mySQLLitColParNom(1,"IDClients ")
ZR1[vindice].lib_departement=monacces:mySQLLitColParNom(1,"Nom")
FIN
FIN
SINON
Erreur(monacces:mySQLGetErrorMessage())
FIN

---


Merci pour votre aide.

Posté le : 2017/6/7 11:21
Transférer la contribution vers d'autres applications Transférer

Sujet Auteurs Dernières réponses
     PHP4WX 9.2.0.0 et utf8 dream 2017/6/7 11:21
       Re: PHP4WX 9.2.0.0 et utf8 Firetox 2017/6/7 11:30
         Re: PHP4WX 9.2.0.0 et utf8 dream 2017/6/7 11:53
           Re: PHP4WX 9.2.0.0 et utf8 Firetox 2017/6/7 11:55





[Recherche avancée]