Login mot de passe
Problème de connexion avec PHP4WM [forum - Accès natifs]

Parcourir ce sujet :   2 Utilisateur(s) anonymes





Problème de connexion avec PHP4WM
Guest_
Bonjour, tout d'abord merci pour votre travail.

Je n'arrive pas à me connecter à une base de données locale ou distante, je veux dire que la connexion à la base depuis le fichier php4wd.php marche, la connexion depuis Windev à php4wd.php marche mais les requêtes renvois soit des chaînes vide soit 0.

Le détail est expliqué plus bas (j'ai suivi à la lettre ce tuto : https://www.youtube.com/watch?v=4y04d-2hc3o)

La copie de la base de données, les fichiers php, la classe et mon projet sont ici (lien valable 1 mois) :
http://78.210.104.213:14694/share/eSR ... robl%C3%A8me%20PHP4WM.rar

Détails :

J'ai créer une base de données nommée : base_test contenant une table (tab_test) qui contient 2 colonne col_id (int, auto incrémente) et col_texte (varchar, max 250)

J'entre deux ligne dans ma table : (col_id = 1 ; col_texte = test 1) et (col_id = 2 ; col_texte = test 2)

J'ai télécharger PHP4WD 7.0.0.6 pour Windev 18 ici : http://www.sqlmanagerx.com/websqlx/ht ... content/index.php?page=17

J'ai ouvert le fichier connect.php et indiquer :
$serv = 'localhost';
$user = 'root';
$pass = '';
$base = 'base_test';

$PublicKey = 'macle';

J'ai ouvert le fichier php4wd.php et indiquer :
/***********************************************************************************************/
/* pour test du fichier en ligne de commande a mettre en commentaire avant passage a windev */
/***********************************************************************************************/
if($_GET['test']=='OUI'){
$typeBase ='PDOMySQL';
$base ='base_test';
$cmds[] = 'SHOW TABLES FROM '.$base;
echo "version script : 8.0.0.0 du 27/11/2016";
}

J'ai copier les fichiers connect.php, php4wd.php et phpzip.php dans C:\wamp\www

J'ai fait le test proposé dans le tuto en tapant http://localhost/php4wd.php?test=OUI et j'obtient :
version script : 8.0.0.0 du 27/11/2016--DEBUTSQL--PHP4WDSEPTables_in_base_testPHP4WDSEPtab_testPHP4WDSEP--FINSQL--PHP4WDSEP

J'ai créer un nouveau projet WindevMobile (sans analyse, nommé PHP4) dans lequel j'importe la classe c_Php4WM.wdc que je convertie en Windev 20

Dans la Déclaration de PHP4WM j'ai mis :
K_PUBLIC_KEY ="macle"

Dans l'Initialisation de mon projet j'ai mis :
MonAccess est un c_Php4WM
SI PAS MonAccess:mySQLConnecte("http://localhost/php4wd.php","","","base_test") ALORS
Erreur("Script non trouvé")
SINON
Info("Script trouvé")
FIN

Puis je créer une fenêtre avec un bouton (nommé BTN_BOUTON) et une zone répétée (nommée ZR_SansNom1, remplie par programmation, 1 colonne)

Je créer 2 libellé dans la zone répétée LIB_id et LIB_texte

Dans le champs Clic de BTN_BOUTON j'indique :
vrequete est une chaîne = "select col_id,col_texte from tab_test"
vindice est un entier

SI MonAccess:mySQLExec(vrequete,1) ALORS
TANTQUE MonAccess:mySQLFetch(1)
vindice = ZoneRépétéeAjouteLigne(ZR_SansNom1)
SI vindice>0 ALORS
ZR_SansNom1[vindice].LIB_id = MonAccess:mySQLLitColParNom(1,"col_id")
ZR_SansNom1[vindice].LIB_texte = MonAccess:mySQLLitColParNom(1,"col_texte")
FIN
FIN
SINON
Erreur("Erreur de co")
FIN

Posté le : 2016/12/7 16:23
Transférer la contribution vers d'autres applications Transférer

Sujet Auteurs Dernières réponses
     Problème de connexion avec PHP4WM Anonyme 2016/12/7 16:23
       Re: Problème de connexion avec PHP4WM Firetox 2016/12/7 17:02
       Re: Problème de connexion avec PHP4WM Firetox 2016/12/7 17:58
       Re: Problème de connexion avec PHP4WM Anonyme 2016/12/8 14:43
         Re: Problème de connexion avec PHP4WM Firetox 2016/12/8 15:46
       Re: Problème de connexion avec PHP4WM Anonyme 2016/12/8 17:21
         Re: Problème de connexion avec PHP4WM Firetox 2016/12/8 17:40
       Re: Problème de connexion avec PHP4WM Anonyme 2016/12/8 18:05
       Re: Problème de connexion avec PHP4WM Anonyme 2016/12/8 18:09
         Re: Problème de connexion avec PHP4WM Firetox 2016/12/8 18:56





[Recherche avancée]