Login mot de passe
[SQLite4WD]Message d'erreur avec mySQLGetFieldType ! [forum - Accès natifs]

Parcourir ce sujet :   1 Utilisateur(s) anonymes





[SQLite4WD]Message d'erreur avec mySQLGetFieldType !
Animateur
Inscrit:
2004/12/14 13:28
De Rennes (35)
Messages: 159
Hors Ligne
Bonjour,

J'ai installé la dernière version (mais je ne suis pas sûr que ce soit lié.

Dans ce code

SI ogPSQLite
:mySQLExec"SELECT * FROM MaTable"0ALORS
  ogPSQLite
:mySQLPremier0)
  
SI PAS ogPSQLite:mySQLEnDehors ALORS
    nv_NbColonnes 
ogPSQLite:mySQLGetNumFields0)
    
nv_NbLignes    ogPSQLite:mySQLGetNumRows0)

    
POUR nl_Col 1 A nv_NbColonnes
      ChampClone
(Col_Modele,"COL_"+NumériqueVersChaîne
        
nl_Col"1d"))
      { 
"Col_"+nl_Col,indChamp}..Visible Vrai
      cl_NomChamp 
ogPSQLite:mySQLGetFieldName0nl_Col)
      { 
"Col_"+nl_Col,indChamp}..Libellé cl_NomChamp
    FIN
    
...
  
fin
fin
ogpSQLite
:mySQLFerme0)

Je précise que nl_Col, nl_NbColonnes sont des entiers et que cl_NomChamp est une chaine
La première mouture, n'utilisait pas cl_NomChamp mais affectait directement la propriété Libelle de la colonne de table.

j'obtiens cette erreur dés la première colonne !

Citation :
Erreur à la ligne 11 du traitement Méthode mySQLGetFieldName.
Vous avez appelé la fonction AppelDLL32.
Une erreur système inattendue est survenue.
Détails techniques : Module : SQLite4WD3.
DLL Adresse de base : 10000000
Erreur système : Access violation (GPF) EIP = 10015E48 OS : Windows XP ou .NET Service Pack 3(5.1.2600)


Qu'est-ce que je fais de mal ?

Posté le : 2009/10/30 16:27
_________________
......
Je ne sais rien, mais je demanderai tout ! .........
Transférer la contribution vers d'autres applications Transférer

Sujet Auteurs Dernières réponses





[Recherche avancée]