Login mot de passe
forum - Tous les messages
   Tous les messages (xorgxxx)

 Bas   Précédent   Suivant

(1) 2 »


#1 Re: Compatible Wn 24 ?
xorgxxx Posté le : 2020/9/8 12:32
Pour info : je viens de migrer le projet en Wn 25 plus de probleme !!

c'est bizard non


#2 Compatible Wn 24 ?
xorgxxx Posté le : 2020/9/8 9:21
Bonjour tout est dans le titre.

je viens de compiler de 22 à 24, en 22 ca fonctionne en 24 il se connecte mais renvoie que des 0?

Cdtl

Ps: je n'ai riens touche aux code n'y sur le serveur n'y dans l'app. j'ai remis la version 22 ça fonctionne. (je pense que ca viendrait d'un probleme SSL)


#3 Re: SQLManagerX 69 erreurs de compilation.
xorgxxx Posté le : 2020/8/29 21:10
Bonsoir je comprend bien.

j'ai regardé pour les commandes basic "crud" 'cest "mysqlinsert" qui reste bien copieuse à porter en Wm.


cdtl


#4 SQLManagerX 69 erreurs de compilation.
xorgxxx Posté le : 2020/8/23 19:22
Bonjour,

j'ai donc toute installé, tout fonction.

j'utilise actuellement les class :
c_Php4Wx, SQLManagerX + plus toutes mes class objet.

tous les test sont au vert! la question que je me pose est la question suivant : le suis sur une machine android "virtuel" cela fonctionne, quand je vais compiler (gradle) le code pour les testes sur un vrai téléphone vais-je avoir des erreurs fatales de compilation avec les 69 erreurs de compilation de SQLManagerX ?

en d'autres termes SQLManagerX est il compatible avec windev mobile, android?

ps: Mes erreurs sont une autre chose

Cdtl

MERCI pour tout le travail effectué sur ce projet !!!!


#5 Re: Probleme ou bug ?
xorgxxx Posté le : 2020/8/17 16:18
Je ne veux pas polémiquer sur mes compétences en windev/php.

Oui avec votre correction "gclPhpWx::CleCryptage" cela a l'air de bien fonctionner.

Petit commentaire : la cle $PublicKey est setter en dure dans connect.php, c_Php4WX (K_PUBLIC_KEY, :CleCryptage = ::K_PUBLIC_KEY), pourquoi l'instancier en même temps que la class? elle existe partout en dure.

Cdlt


#6 Probleme ou bug ?
xorgxxx Posté le : 2020/8/17 15:35
bonjour

dans le initialisation du projet

gclFicore est un CL_FiCore
("FEN_Main""CFI_Main")     
gclPhpWx est un c_Php4WX 
gsHashMd5Ctx     est une chaîne 

//gclPhpWx:TypeBase         = "PDOMySQL" //gclPhpWx:CleCryptage     = "6d82c91d82d4fae79ede380da82691d1" 
//gclPhpWx:CryptRetour     = Faux //gclPhpWx:methodeZip        = Faux 
//gclPhpWx:dataHexa         = Faux //gclPhpWx:modeUTF8Entree = Vrai 
//gclPhpWx:modeUTF8Sortie = Faux   
// 
SI gclPhpWx:mySQLConnecte("https://www.xxxxxx.com/phpcspi-20019/php4wd.php""","","stockholm"ALORS  

SINON     
Erreur
(gclPhpWx:ErreurText)   !!! a noter qu'il ne stop jamais !!!
FIN


code du bouton


req est une chaîne 
"select * from product"  
SI gclPhpWx:mySQLExec(req,1ALORS          
Info
("'ok'"
SINON     
Erreur
(gclPhpWx:mySQLErreur
FIN


https://www.xxxxxx.com/phpcspi-20019/php4wd.php =>
version script : PHP4WX 9.2.0.15 du 25/06/2019
Source non identifiée, acces refusée

https://www.xxxxxx.com/phpcspi-20019/php4wd.php?test=OUI =>
version script : PHP4WX 9.2.0.15 du 25/06/2019 version php : 7.3.16
--DEBUTSQL--PHP4WDSEPidPHP4WDSEPhash_idPHP4WDSEPnamePHP4WDSEP ............

le serveur fonctionne, mais quand je test depuis windev 22 il "Erreur(gclPhpWx:ErreurText) " 0

la je vois pas bien ??

pour info : je pensais que c'etait mon fork qui merdait, alors j'ai pris la version php4wx d'origine exactement le même problème

Cdlt


#7 Re: quelle sont les "versions" supporté
xorgxxx Posté le : 2020/8/16 17:17
ah ok!! je pensais que l’accès, les requêtes étaient toutes joués sur cette url. autant pour moi.

donc il n'y rien a faire de plus.

cdlt


#8 Re: quelle sont les "versions" supporté
xorgxxx Posté le : 2020/8/16 15:48
Yes.

donc j'ai déjà le Php4WX a la sauce Symfony en php7.4 -> PDOMysql cela fonctionne très bien. bon il y a un truc qui me gêne, pas de sécurité sur l'url mais bon un JWT fera le job.

je me suis mal exprimé : le total par requete ne va pas exeder 200 KO, par contre +10.000 utilisateurs, le tout sur un max serveur dédié + fibre, apres les user's c'est leur probleme 1G, 2G, 3G, ou 4G ......

Cdlt


#9 Re: quelle sont les "versions" supporté
xorgxxx Posté le : 2020/8/16 13:20
Merci, je vais donc me pencher dessus, probablement l'updater, et le mettre a la sauce Symfony.

au niveau du "benchmark" il y a t-il des limites? je dois avoir un gros débit de requêtes (10.000/h, en plus des access web) avec des rafraîchissement automatique.

cela va t’il tenir le choc selon vous ?

Cdlt


#10 Re: quelle sont les "versions" supporté
xorgxxx Posté le : 2020/8/16 10:30
Merci de la rapidité de votre réponse .

dans le code du connect.php, j'ai vue beaucoup de codes obsolète en php7+ (toutes ces fonctions ont êtés supprimé de php7)

return mysql_query($query, $sess);
$erreur = mssql_get_last_message();
$res = mssql_init($query);
mssql_bind($res,$bin[$i],$biRes[$i], $msType,$TypeParam);
$resExec = mssql_execute($res);
while(mssql_next_result($resExec)){
$Session = mysql_connect($serv, $user, $pass);
.....

cela rend-il pas la version instable pour fonctionner correctement ?

Cdlt



 Haut
(1) 2 »