Login mot de passe
forum - Tous les messages
   Tous les messages (Coolbreeze)

 Bas   Précédent   Suivant



#1 Re: Problème "source non identifiée. Accès refusée"
Coolbreeze Posté le : 8/20 17:00
bonjour,

je viens de refaire tout depuis le début avec WAMP et cela fonctionne. j'ai donc tout refais via la base en ligne mais toujours le même problème. je vais donc pouvoir avancer dans la programmation de l'app et je verrai après la mise en place de la DB en ligne

merci encore pour toute les infos

Je passe le sujet en résolu car ça doit en effet être un problème de variable ou autre mal orthographié

bonne journée


#2 Re: Problème "source non identifiée. Accès refusée"
Coolbreeze Posté le : 8/19 7:57
Salut,

VOici ce que j'ai comme message dans le chaine result :
<!DOCTYPE html><meta http-equiv="content-Type"content="text/html;charset=UTF-8"/><p class='Perror'>Failed-err SQL: </p> SELECT nomTech FROM reponse

--> La clé de cryptage est la même
--> la requete que j'utilise dans test est la même
--> les noms de colonne et de table MYSQL sont bien orthographié
--> Pour moi la requete sql est en bonne forme (il y a 3 noms dans la db)


code d'ini sur windev:

gclMonAcces
:TypeBase "MYSQLI" 
gclMonAcces:CleCryptage "macletest"
gclMonAcces:CryptRetour Faux 
gclMonAcces
:CrypteReq Faux 
gclMonAcces
:methodeZip=Faux 
gclMonAcces
:dataHexa Faux 
gclMonAcces
:modeUTF8Entree Vrai gclMonAcces:modeUTF8Sortie Faux 
gclMonAcces
:charset "utf-8" 
gclMonAcces:alphabet alphabetUTF8


mon code pour la requete

sRequete est une chaîne 
"SELECT nomTech FROM reponses"
nIndice est un entier

ZoneRépétéeSupprimeTout
(ZR_rep)

SI gclMonAcces:mySQLExec(sRequete,1ALORS //--> erreur lors de l'execution de la requete
    
TANTQUE gclMonAcces:mySQLFetch(1)
        
nIndice ZoneRépétéeAjouteLigne(ZR_rep)
        
SI nIndice>0 ALORS
            ZR_rep
[nIndice].LIB_nomTech        gclMonAcces:mySQLLitColParNom(1,"nomTech")            
        
FIN
    FIN        
SINON
    Erreur
(gclMonAcces:mySQLGetErrorMessage())
FIN


#3 Re: Problème "source non identifiée. Accès refusée"
Coolbreeze Posté le : 8/18 11:02
C’est bien le problème il ne m’indique pas d’erreur sql ...

J’ai le texte HTML qui s’imprime mais blanc pour la variable d’erreur


#4 Re: Problème "source non identifiée. Accès refusée"
Coolbreeze Posté le : 8/18 9:30
En effet c'est ce que j'e me disait.J'ai donc bien ciblé mon erreur mais je ne vois pas ce que sont les séparateurs ?

Je suis sur une base MYSQLI

Mon querry est "Select nomTech from reponses"

et l'erreur se situe ici


// si on a pas les separateur alors il y a une une erreur
// on ne fait pas le traitement suivant on renvoie simplement le retour du script php 
SI Position(v_chaineResult,"--DEBUTSQL--PHP4WDSEP") = 0 ALORS 
:ErreurText v_chaineResult 
RENVOYER
(Faux)
FIN


Merci d'avance et désolé pour cette ignorance


#5 Re: Problème "source non identifiée. Accès refusée"
Coolbreeze Posté le : 8/17 20:38
Merci FireTox,

J'ai tout recommencer et maintenant je n'ai plus l'erreur

J'en ai une autre failed err SQL
Je vais me pencher la dessus


#6 Problème "source non identifiée. Accès refusée"
Coolbreeze Posté le : 8/17 15:09
Bonjour,

Je suis nouveau avec ce systeme Alternatif et je galère un peu.
J'ai suivi le tuto sur Youtube en pour connecter une bd MYSQL à mon projet windev.

J'ai commencé par connecté à une DB en ligne:

quand je met monsite.com/php4wd.php
--> j'ai l'erreur source non identifiée accès refusée

quand je fais le test monsite.com/php4wd.php?test=OUI
--> il affiche bien le resultat de la requete SQL

j'ai donc linké tout ça avec Windev Mobile 22 et quand je lance mon appli (toujours avec le même exemple que dans le tuto) --> j'ai l'erreur source non identifiée ...

j'ai donc décider de commencé avec une DB en locale et WAMP
mais exactement le même problème ..

pouvez-vous m'aider svp?

D'avance merci



 Haut