Login mot de passe
forum - Tous les messages
   Tous les messages (Firetox)

 Bas   Précédent   Suivant

(1) 2 3 4 ... 183 »


#1 Re: Un message derreur de chargement de donnees
Firetox Posté le : 11/16 8:17
bonjour,

quelle est la version de la classe et des scripts ?
sinon essayez ce code


vrequete est une chaîne 
"SELECT idNiveau,libelleNiveau FROM niveau ORDER BY libelleNiveau ASC "
ListeSupprimeTout(COMBO_niveau)
SI MonAccess:mySQLExec(vrequete,1ALORS
    TANTQUE MonAcces
:mySQLFetch(1)
        
ListeAjoute(COMBO_niveau,monAccess:mySQLLitCol(1,2))
    
FIN
SINON
    Erreur
("Erreur n° " monAccess:mySQLErreurmonAccess:mySQLGetErrorMessage())
FIN
monAccess
:mySQLFerme(1)


mais important : la vesion utilisée
sinon comme je l'ai dit sur le message precedent peut etre le fait que ce code soit lancé en simultané quelque part


#2 Re: Un message derreur de chargement de donnees
Firetox Posté le : 11/15 17:20
Bonjour,

tu as le code de chargement de la combo
et / ou du clic sur le bouton

essaye de recrer l'erreur en faisant un double clic sur le bouton. je pense a cela car ce serait 2 requetes envoyer avec le emem numero et les tableau de resultats sont dependant de l'instance

donc sur clic du bouton il faudrait empecher un nouveau clic car si la premeire requete n'est pas finie il se peut qu'on est ce message


#3 Re: Problème "source non identifiée. Accès refusée"
Firetox Posté le : 8/20 13:50
bonjour,

bizarre, si le script marche en mode test alors il doit y a voir une difference entre le code executé par le mode test et le mode windev et la ce sont uniquement les parametre typeBase, la cle de cryptage qui entrent en jeu

verifiez bien les maj et minuscules mais j'avoue ne pas voir ce qui cloche


#4 Re: Problème "source non identifiée. Accès refusée"
Firetox Posté le : 8/18 16:17
qu'est ce qu'il y a dans chaineResult

sinon si la partie test fonctionne il faut essayer avec la meme requete
mais voir egalement le typeBase dans le progWindev
pour msqli par exemple c'est MonAcces:TypeBase="MYSQLI"

il faut mettre les meme parametre que dans la partie test du script php4WD.php surtout pour le type base car si cela marche dans la partie test cela doit fonctionner depuis windev

mais avec les meme parametre sur typebase


#5 Re: Problème "source non identifiée. Accès refusée"
Firetox Posté le : 8/18 9:42
bonjour,

ce n'est pas une erreur la requete n'a pas pu s'executer correctement que donne le erroreText
car c'est un probleme SQL


#6 Re: Problème "source non identifiée. Accès refusée"
Firetox Posté le : 8/17 20:43
bonsoir,

dans ce cas c'est une erreur au niveau de la requete
il doit renvoyer le pourquoi et la reqete qui est partie pour trouver

mais la c'est le SQL donc voir la requete

cdlt


#7 Re: Problème "source non identifiée. Accès refusée"
Firetox Posté le : 8/17 18:21
bonjour,

ce probleme est souvent du au fait que la cle n'est pas la meme dans le fichier connect.php et le programme windev
une cle d'origine du script est crypté avec la cle de cryptage que le script decrit si la chaine decrypté ne correspond pas a la chaine qu'il attent il envoie ce message

voir le Post :
https://forum.sqlmanagerx.com/modules/ ... .php?topic_id=934&forum=1

mais je pencherais sur la cle de cryptage qui n'est pas la meme dans le fichier et le programme windev


#8 Re: Poblème avec php4wx en ligne
Firetox Posté le : 8/13 13:41
bonjour,

bizarre si je fais le meme test voici le source que je recupere et il n'y a aucune reference a un script

<!DOCTYPE html><meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />version script : <b>PHP4WX 9.2.0.15 du 20/06/2019</b><br>version php : <b>5.5.38</b><br><br>Erreur SQLSTATE[42S02]: Base table or view not found1146 Table 'EMIDEV_BATACARTE.contacts' doesn't exist

il n' y a pas dans les script de reference a aes.js
je ne sais pas d'ou viennent ces lignes mais elles doivent etre rajoutée par l'hebergeurs a ce moment la car normalement on doit avoir une sources html hyper simple comme celui que je viens de mettre

dans le script php zaucun lien sur un script javascript donc quelque chose est rajouté par votre hebergeur ou le serveur web d'ou le probleme : il ne doit y avoir aucun rajout dans les scripts d'origine

avec un mobile voici le retour dans mySQLEXec:

<!DOCTYPE html><meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />--DEBUTSQL--PHP4WDSEPpseudoPHP4WDSEPemailUserPHP4WDSEPpassUserPHP4WDSEPNomPHP4WDSEPPrenomPHP4WDSEPTelephonePHP4WDSEP--LIGNES--PHP4WDSEPFIRETOXPHP4WDSEPemprin.frederic@emidev.frPHP4WDSEP93 D6 37 81 B2 7B DA 9D 6B 81PHP4WDSEPEMPRINPHP4WDSEPFrédéricPHP4WDSEP0672601786PHP4WDSEP--BINDVARIABLE--PHP4WDSEP--FINSQL--PHP4WDSEP


je n'ai pas de script java appelé
et le programme fonctionne tres bien sur io et android donc a voir pourquoi vous avez cette partie en plus depuis votre hebergeur


#9 Re: Poblème avec php4wx en ligne
Firetox Posté le : 8/12 12:42
bonjour,

en fait j'utilise mon prop acces (emidev.fr : serveur dédié avec bcp d'espace)

par contre j'ai des clients qui utilisent les acces gratuit comme (Free, certain OVH etc..) aucun souci pour ces acces
sinon voir sur cette liste

https://korben.info/hebergement-web-gratuit-2019.html

mais sur des acces gratuit avec php et mysql jamais eu aucun souci car les serveur mysql sont accessible uniquement depuis l'espace web definit avec toutes les autorisation et donc php4wx fonctionne super bien a dessus : toute fois attention a la cle de cryptage : certain FAI n'aiment pas les caractee speciaux donc mettez une cle avec majuscules et chiffre mais sans caractere speciaux mais cela reste a tester car si le FAI accepte alors mettz des caracteres spéciaux)

voila en esperant que vous trouverez votre solution gratuite facilement)

cordialement


#10 Re: Poblème avec php4wx en ligne
Firetox Posté le : 8/12 11:24
bonjour,

peut être j'avoue ne jamais avoir eu ce probleme sur android toutes version et iphone du 4 au dernier
je pencherais sur un probleme du FAI car je ne pense pas que windev mobile face cela mis a part si c'est autre chose qu'android (windows phone par exemple) vu qu'il va etre arreté je ne fait pas de test sur l'os.

pour windev avec les erreur javascript il faut mettre une chos dans la base de registre (la version de ie utilisée avec la commande : registreEcrit ) voir sur https://unblogdetrop.com/blog/billet/7 ... hamp-html-version-ie.html pour de plus ample renseignement

cette partie m'a permis de regler pas mal de soucis avec le champs html ou le web browser en active x



 Haut
(1) 2 3 4 ... 183 »