Login mot de passe
forum - Tous les messages
   Tous les messages

 Bas   Précédent   Suivant

« 1 ... 479 480 481 (482)


#4811 Re: [ORACLE4WD] Erreur qui ne remonte pas
Laurent Posté le : 2005/6/24 8:28
Salut,

J'ai du mal avec cette nouvelle présentation...

Citation :
une requete select qui tombe en erreur ? jamais vu peut-etre un update ou delete ... tu as un exemeple stp.


Heu, chez moi les SELECT remonte de temps en temps des erreurs... quand je me plante bien entendu.

Pas d'exemple complet qui ne voudrait rien dire mais voici le principe. Il s'agit d'une requête qui en gros remonte un montant et le comparer au montrant du mois d'avant pour ne prendre que ce qui change.

Donc :

SELECT mes rubriques
FROM mes tables
WHERE mes jointures
AND MonMontant <> NVL(SELECT qui recherche la fiche du mois dernier, 0)

S'il y a un montant, il est comparé...
S'il n'y a pas de montant la valeur zéro est prise pour comparaison.
S'il y a plusieurs montants (pas normal), la requête complète me dit qu'il n'y a pas de données sans message d'erreur, alors que la même requete (copier/coller) sous SQL+ me retourne une erreur.

Voilà. en ce qui me concerne j'ai mis dans la requête ce qu'il faut pour eviter de remonter plusieurs lignes pour cette sous requête. En espérant avoir permis d'avancer dans votre fabuleux travail.


#4812 Re: [ORACLE4WD] Erreur qui ne remonte pas
manu Posté le : 2005/6/23 17:23
query="UPDATE manu SET manu.LIB_TYPE = (SELECT id_type FROM OPERATION)"

SI PAS convSql:mySQLExec(query,3)
convSql:mySQLMsgBox("erreur Exec")

plante sur l'erreur ORA-01427


#4813 Re: [ORACLE4WD] Erreur qui ne remonte pas
manu Posté le : 2005/6/23 17:20
Citation :
1°) Oracle4WD ne me signale rien et termine la requête par un résultat nul. C'est à dire aucune ligne remonté.


une requete select qui tombe en erreur ? jamais vu peut-etre un update ou delete ... tu as un exemeple stp.


#4814 [ORACLE4WD] Erreur qui ne remonte pas
Firetox Posté le : 2005/6/22 20:31
Salut,

Désolé pour n'intervenir uniquement pour des problèmes que je rencontre avec l'accès Oracle. J'en dit pourtant souvent du bien

Bon, j'ai une requête qui dans la zone WHERE lance une sous-requête pour récupérer une valeur. Normalement il s'agit d'une requete mono-ligne. J'ai malheureusement eu le cas ou cette sous-requêtre remontait plus d'une ligne.

1°) Oracle4WD ne me signale rien et termine la requête par un résultat nul. C'est à dire aucune ligne remonté.

2°) La même requête sous SQL+ me signale que la sous-requête 'Machin' remonte plus d'une ligne.

QUESTION à 1 Euro. Est-il possible d'avoir le même comportement avec Oracle4WD ?

Merci pour tout et bonne soirée à tous.



 Haut
« 1 ... 479 480 481 (482)