Login mot de passe
forum - Tous les messages
   Tous les messages

 Bas   Précédent   Suivant

« 1 2 3 (4) 5 6 7 ... 489 »


#31 Re: Ajout Image à partir de WM et affichage image à partir de Windev
Mister_jp Posté le : 1/31 10:22
Bonjour
Desolé d'avoir mis du temps mais j'ai essayé un peu tout afin de regler mon soucis mais j'ai a chaque mon appli qui se plante et redemarre.Mon soucis actuellement est de savoir comment enregistrer l'image prise par l'appareil photo.
Mon code pour le bouton enregistrement:

//COMBO_Type_de_bien..ValeurAffichée="Terrain"
bufVImage est un Buffer = dSauveImagePNG(IMG_Capture,enMémoire)
sCheminImage est une chaîne = fRepEnCours() + "\MonImage.png"
bufImage est un Buffer = fChargeTexte(sCheminImage)
SI bufImage<> "" ALORS
bufImage = "0x"+Remplace(Remplace(BufferVersHexa(bufImage),RC,""),"","")
sImage est une chaîne = bufImage
SI MonAcces:mySQLExec("insert into `Terrain` (`superficie_terrain`,`prix_vente_terrain`,`prix_m_terrain`,`photo_terrain`,`latitude_terrain`,`longitude_terrain`,`rue_terrain`,`commune_terrain`,`ville_terrain`,`region_terrain`,`pays_terrain`,`date`) values("+ONG_Terrain.SAI_Superficie_terrain+","+ONG_Terrain.SAI_Prix_terrain+","+ONG_Terrain.SAI_Prix_m_terrain+","+MonAcces:mySQLEscapeString(sImage)+","+SAI_Latitude+","+SAI_Longitude+","+MonAcces:mySQLEscapeString(sRue)+","+MonAcces:mySQLEscapeString(sCommune)+","+MonAcces:mySQLEscapeString(sVille)+","+MonAcces:mySQLEscapeString(sRegion)+","+MonAcces:mySQLEscapeString(sPays)+","+SAI_Date+")",1) ALORS
Info("Enregistrement Terrain Effectué")
Ferme()
SINON
Erreur(MonAcces:mySQLGetErrorMessage())
FIN


#32 Re: Ajout Image à partir de WM et affichage image à partir de Windev
Mister_jp Posté le : 1/23 16:32
Bonjour

Merci pour la réponse
mon typebase est mysql.Je vais essayer comme indiquer dans l'exemple mais mon est de savoir comment utiliser cette ligne : "vimage est un Buffer = fChargeTexte("G:\EMIDEV\Commercial\logo\yeux.png")" vu que a mon niveau l'image qui est prise deppuis le telephone doit s'afficher dans le champ image et aller dans la base et sera utilisée plus tard pour afficher dans une autre application utilisant cette meme base.Neanmoins j'essaie te je vous fait un retour.

Merci


#33 Re: Gros soucis d'import HF
Firetox Posté le : 1/23 14:35
oki

je vais voir d'ici 5 jours (car ce week je vais mettre a jour 11 bases HFSQL sur des serveurs pour prendre en compte une maj analyse et le prog qui va avec )

mais je pense que mardi 28/01/2020 j'aurais un peu de temps pour enlever la casse ou du moins ne pas en tenir compte et voir ce que je dois modifier dans le dataCenter

voila
@+


#34 Re: Ajout Image à partir de WM et affichage image à partir de Windev
Firetox Posté le : 1/23 14:33
bonjour,

dans le poste pour utiliser php4WX j'ai mis une infos la dessus
car cela depend du mobile et de la façon dont il code l'image et il y a une façon simple que j'utilise

l'explication est la : https://forum.sqlmanagerx.com/modules/ ... .php?topic_id=934&forum=1

a defiler et voir comment inserer une image et la lire (exemple sur mySQL) car les autre base il faudrait faire la meme chose


#35 Ajout Image à partir de WM et affichage image à partir de Windev
Mister_jp Posté le : 1/21 16:43
Bonjour

J'ai une apllication mobile qui sert a prendre des données terrain avec photo prises a partir de l'appareil du telephone ou des images dans le telephones.Ces images sont ajoutées dans un LONGBLOB dans ma base.
J'ai une application windev qui sert a afficher les données enregistrées sur ma base et qui doit afficher les images prises depuis l'application mobile.Le souci est que je n'arrive pas a afficher ces images dans mon tableau .

Voici les differents codes:

//Image à partir de l'appareil photo

sFichierImage est une chaîne
sFichierImage = VidéoLanceAppli(viCaptureImage)
SI sFichierImage <> "" ALORS
bufImage est un Buffer
bufImage=dSauveImageJPEG(IMG_Capture,enMémoire)
IMG_Capture = sFichierImage
FIN



//Image prise dans le telephone

sFichierImage est une chaîne
sFichierImage = AlbumSélecteur(albumImage)
SI sFichierImage <> "" ALORS
bufImage est un Buffer
bufImage=dSauveImageJPEG(IMG_Capture,enMémoire)
IMG_Capture = sFichierImage
FIN





//Ajout des information avec mobile


sFichierImage est une chaîne = IMG_Capture
SI MonAcces:mySQLExec("insert into `Terrain` (`superficie_terrain`,`prix_vente_terrain`,`prix_m_terrain`,`photo_terrain`) values("+ONG_Terrain.SAI_Superficie_terrain+","+ONG_Terrain.SAI_Prix_terrain+","+ONG_Terrain.SAI_Prix_m_terrain+","+MonAcces:mySQLEscapeString(sFichierImage)+",1) ALORS
Info("Enregistrement Terrain Effectué")
//Ferme()
SINON
Erreur(MonAcces:mySQLGetErrorMessage())
FIN




//Code Affichage sur apllication windev


vindice est un entier
vrequete est une chaîne = "SELECT IDTerrain,superficie_terrain,prix_vente_terrain,prix_m_terrain,photo_terrain,Latitude_terrain,longitude_terrain,rue_terrain,commune_terrain,ville_terrain,region_terrain,pays_terrain,date FROM Terrain ORDER BY IDTerrain DESC "
//SI pwhere <> "" ALORS vrequete+=" where adresse like '%"+pwhere+"%'"

//ZoneRépétéeSupprimeTout(ZR_contacts)
TableSupprimeTout(TABLE_Terrain)

SI MonAcces:mySQLExec(vrequete,1) ALORS
TANTQUE MonAcces:mySQLFetch(1)
// sur chaque ligne action a faire
vindice = TableAjouteLigne(TABLE_Terrain)
SI vindice>0 ALORS
TABLE_Terrain[vindice].COL_Identifiant = MonAcces:mySQLLitColParNom(1,"IDTerrain")
TABLE_Terrain[vindice].COL_Superficie = MonAcces:mySQLLitColParNom(1,"superficie_terrain" )
TABLE_Terrain[vindice].COL_Prix_vente = MonAcces:mySQLLitColParNom(1,"prix_vente_terrain" )
TABLE_Terrain[vindice].COL_Prix_m = MonAcces:mySQLLitColParNom(1,"prix_m_terrain" )
TABLE_Terrain[vindice].COL_Photo = MonAcces:mySQLLitMemo(1,5)

FIN
FIN
SINON
Erreur(MonAcces:mySQLGetErrorMessage())
FIN


#36 Re: Gros soucis d'import HF
JMDGFR Posté le : 1/21 0:17
Pas de soucis ... cela n'urge pas ..... tu as déjà beaucoup fait ... et c'est dur de se passer de toi


#37 Re: Gros soucis d'import HF
Firetox Posté le : 1/20 14:41
bonjour,

oui je pense aussi a cela le problème de la casse
je peux faire quelque chose mais uniquement la semaine prochaine car je suis en déplacement depuis pas mal de semaine et je rentre juste le week-end et parfois même pas le temps de me plonger dans windev

mais je vois très bien donc il faudrait que j'apporte des modif pur éviter les maj et autre (mais pas facile comme ca j'ai deja eu des nom avec ou nom des maj mais avec des minuscule bref il faudrait un peu de temps pour voir et comprendre et faire les modifs

mais actuellement j'ai pas énormément de temps
j'aurais aimé en avoir plus mais pour non pour l'instant


#38 Re: Gros soucis d'import HF
JMDGFR Posté le : 1/15 16:15
J'ai fais les test avec une base Firebird et pas de soucis je peux tout importer de HFSQL vers Firebird.

Avec PostGresQL, impossible .... Il y a donc un soucis soécifique à PGS quand je veux importer une table HFSQL dans une table PGS ....

Je pense que c'est peut-être lié aux majuscules/minuscules (Tables en minuscules sur PGS et Majuscules dans l'analyse Windev .....) Grrrrrrr or je n'arrive pas à faire passer en miniscules l'analyse windev ....

Je n'ai rien dans les fichiers de création ou d'erreur.
Comme si d'emblée le DATACENTER détecte que cela va foirer et ne copie rien même sous forme d'insert dans un fichier texte ...


#39 Re: Gros soucis d'import HF
JMDGFR Posté le : 1/9 1:23
Salut,

J’ai fait comme ça ......
Il ne semble pas détecter les donnés ......

Problème de.analyse ?


#40 Re: Gros soucis d'import HF
Firetox Posté le : 1/7 15:39
bonjour,

ce qu'il faut c'est faire l'import en deux partie : creation des table et ensuite import des datas certains cserveur n'aiment pas creer les table et import directe

sinon faire l'import en mode fichier
pas envoyer les requetes sur le serveur : le dataCenter va creer une fichier create.log avec toutes les requetes

en prendre une vet voir ce qui se passe



 Haut
« 1 2 3 (4) 5 6 7 ... 489 »